Thornton crashes the game

  • Member of the Month for May.......Bamaracing

Mr.Noob

Member
Cold Pass Member
Oct 29, 2018
1
3
So i recently got a better laptop because my old one sucks. So i had to install nr2003 again. The first thing i tried to do was to get the Windy City Racing tracks because those are lots of fun. When I got thornton and sarted a race however, i would go about 100 feet before the game crashed or, my screen would freeze (with the game still running). The track works perfectly normal in testing mode and i was just so confused. I tried different mods, different cars, and it still has the same problem. Other tracks work perfectly normal and i have never seen this happen in all my time playing nr2003. Thornton also worked with my old laptop so i don't know what is causing the game to crash.
 

MoonShibe64

Well-Known Member
Hot Pass Member
Nov 13, 2016
111
43
Back when i was on Windows 7 with my old computer (Intel Core i5 4440 and GTX 760) it refused to work unless i turned everything down to the lowest, that my help?
 

garrett1127

Co-Owner
Staff member
Administrative
VIP
Co-Owners
Jul 23, 2016
4,448
163
Do you still have access to your old computer, if you do, compare the files from the track to each other. Other than that, with the limited info you posted, there's no clue to what would cause it.
 

Mr.Noob

Member
Cold Pass Member
Oct 29, 2018
1
3
I turned everything down but it didnt work but ill see if my old computer has the same files
 

Mr.Noob

Member
Cold Pass Member
Oct 29, 2018
1
3
i figured out the error. I use directx as my graphics source and i tried with opengl, and it works. the graphics however arent the best and i dont want to switch everytime. i have directx 12 so is there a version i have to get instead?
 

garrett1127

Co-Owner
Staff member
Administrative
VIP
Co-Owners
Jul 23, 2016
4,448
163
You may have to go down to ver 9c, not the smartest guy here on such things, what os are you using, and your vid card?
 

Mr.Noob

Member
Cold Pass Member
Oct 29, 2018
1
3
*update* i was messing around with settings and the only way it works is that if i turn down the display to 800x600
i use windows and a intel(R) UHD graphics 620 card. but whats weird is that my old computer also has directx 12 so i dont know why my better graphics card wouldnt work
 
Last edited:

Mr.Noob

Member
Cold Pass Member
Oct 29, 2018
1
3
i have windows 10, but i dont know how to tell wether the graphics card is integrated or stand alone
 

Blitzman

Member
Cold Pass Member
Feb 23, 2019
4
3
Hi,
I think I remember it giving some problems here n there back when. I think it had a or some bad 3D model(s) in it.

Did you try pressing "o"(the letter O and not number zero)?
That toggles thru showing different levels of objects, low/none? to Medium to All.
I think though deselecting things in graphics settings may have the same effect but maybe handled differently so try that.

I made a long track back when in Sandbox and I must have fudged a 3D model I made because it gave similar problem, as soon as passing pit line it seemed it would crash. If I turned objects off I think it ran.

It did run(same as you found in Thornton) when set to OpenGL. The performance was always a bit choppy though.
Sandbox would crash when I tried to remove bad items so I could not fix the track and unfortunately only kept some earlier saves with not nearly as finished as I had it.
I could go no further with it as Sandbox would refuse.

Seems like different Direct X implementations in different Video cards have problems. My track ran until when I upgraded my PC very shortly after making the track(would have noticed the problem in making it when I got to the point where the offensive object was added). Would have maybe been able to undo and make a save then at that point.

Make sure you run the 3D config program of NR2k3.

I wonder if picked apart that the bad entries could be found and fixed? Pretty sure a 3D object with bad geometry somewhere or so is the culprit.

Well best to you n all.

Peace,
Blitz
 

Mr.Noob

Member
Cold Pass Member
Oct 29, 2018
1
3
I’ve already tried turning the trackside objects down, and it still didn’t work but you could be on to something.
 

Cynon

Active Member
Cold Pass Member
Hot Pass Member
Jan 5, 2017
87
18
Was it only car shadows, or was it the cockpit shadows? Because the root cause for those might be elsewhere.

Reason I ask is that I had a similar problem pop up with a different mod on a different track.
 

Mr.Noob

Member
Cold Pass Member
Oct 29, 2018
1
3
well now i applied full shadows and it works so maybe the shadows had an error when loading in so problem solved
 

Blitzman

Member
Cold Pass Member
Feb 23, 2019
4
3
well now i applied full shadows and it works so maybe the shadows had an error when loading in so problem solved
Right on, glad Ya got er working! Maybe a glitch in the file...

This had gotten me thinking of an old track I was trying to complete(I mentioned above) and got to messing with one of my old PCs to figure what I was going to do with it and fired it up and got to looking at the NR2k3 stuff saved there and found a zipped file of when I was making that track and all the original raw files!
I had posted more about it in the "Introduce Yourself" area.

I think I got my old track to work anyway LOL.

Need to see how it was one would pack em up, I think I have MakeDat or something.
Have to see if it will still work. Then I'll post if wanted.

Peace!
Blitz
 

Our Partners